No announcement yet.

3-Way Dimmer Switches Behave Differently Depending on Cross-linking Method

  • Filter
  • Time
  • Show
Clear All
new posts

  • 3-Way Dimmer Switches Behave Differently Depending on Cross-linking Method

    I set up two dimmers to control the light over the dining table. But they're not behaving correctly when I link them. Interestingly, they fail in opposite ways depending on if I crosslink manually vs. using a scene through the hub/app. Here are the steps to recreate my issue…

    1. I added both devices to the hub and set their default to 75%. At this point, only one of them actually controls the light.
    2. Manual method: I cross-linked the dimmers using the control buttons. At this point the main switch acts as expected: tap on once and it's 75%; tap on a second time and it's 100%; tap on to toggle between both states. However, the secondary switch only switches from off to 100%. The LED correctly indicates the assigned logic (i.e. on = 75%, then 100%, etc.), but the dining light is at 100% regardless of what the LED says. It can dim as expected if I hold the rocker up or down.
    3. App scene method: I created a scene with both lights set to BOTH and set each to 75% on. The primary dimmer works as expected, and the secondary acts as above where the LED indicates correctly but the dining light doesn't change. The difference here is that instead of being stuck at 100% it's stuck at 75%.

    What is going on here? I have consistently recreated this error on three different 3-way setups in the house. I've not been able to get any of them to work where the secondary switch works as expected.

  • #2
    The key for manual linking is that the responding switches need to be at the correct dim level when you link to them.

    lets say you link two switches together as a three way. One switch we will call switch A and the other B

    if A is set to 75% when you link it to switch B then B needs to also be set to 75% when you manually link them.

    Switch A preset level has no effect over The level of B.
    Having B at the appropriate level when linked to A will give the desired result.


    • #3
      I set A and B both to 40% (in this case). I first linked A to B (by holding down the program button on A until it turned green, then doing the same on B). Then I did the reverse, B to A. In both cases I had them set to 40%. As soon as I linked B to A, A seemed to have forgotten its new default setting of 40% and instead defaults to ON. I imagine I didn't get something right here, but it seems like I followed your instructions and got the wrong result. What am I missing?


      • #4
        You should not be manually linking any device if you have a hub as part of the system. Doing so only complicated things when trying to troubleshoot.

        I would remove the devices from the hub, factory reset to clear out any stay or incorrect links already in them. Since you want them manually linked, once factory reset following Steve's instructions.

        The device is not in linking mode until you hear a chirp and the device starts blinking. You'll then go to the next device, press and hold it's set button until you hear a double chirp and the blinking should stop on the first device. You then do the same in reverse.

        It's far easier in the hub. Add the 2 devices to a scene using "both" and then set the light level for the scene. Save and your done


        • #5
          Per my top statement, I have found that linking manually and via the hub both result in it not properly working. I will use the hub to set timers and control switches through Alexa, but if the Wi-Fi goes out, I want the switches to know what's what, hence manual linking. Regardless of method, it's not working predictably in either scenario.


          • #6
            Per my statement all links should be done in the hub. All links are set at the device level when done withwthe hub. By linking both manually and through the hub, you're actually introducing potential complications (especially if done incorrectly) by overwriting the links already created.

            I would try factory resetting the devices to ensure a clean slate and then try again.
            Last edited by lilyoyo1; 04-16-2019, 03:33 PM.


            • #7
              I second lilyoyo’s advice—start by performing a factory reset on both switches. Also delete the scene you created with the Hub.

              [QUOTE]but if the Wi-Fi goes out, I want the switches to know what's what, hence manual linking.[/QUOTE]

              The manual linking is not necessary, the Hub app does the direct switch-to-switch linking for you. If your WiFi goes down, all you lose is the bridge from WiFi to Insteon, the communication between members of the scene continues to operate normally.

              BTW, when you create the scene, you want to add each switch with a mode of BOTH (both Controller AND Responder) in order to create those cross-links.

              If, after performing the above steps, it still does not work as expected, prepare to provide the specific model number on the back of each switch involved. Different models of Insteon controllers offer different features (single vs. dual band, RF vs. power line, master vs. slave on the original 2-wire kits, etc.) which suggest different troubleshooting.
              Last edited by TFitzpatri8; 04-16-2019, 08:28 PM.


              • #8
                It's helpful to know the hub will update the hardware!

                So, yep, I factory reset everything, removed the devices from the hub and added them back in. Then I created a scene and set both dimmer switches to "both," and set each 33% with a medium ramp rate. Let's call the switches A and B. A is the master, with the load wired to the fixture, and B is just taking power from traveler and neutral.

                Scenario 1: the switches have factory default settings
                - Tap on switch A and the lights ramp up to ON, the LED indicates ON
                - Tap on switch B and the lights ramp up to 33%, the LED indicates ON, tap on again and the LED indicates ON but the lights don't change

                Scenario 2: set switch A default to 33%, B is still at factory default
                - Tap on switch A and the lights ramp up to 33%, the LED indicates 33%, tap on again and ramps to ON with the LED indicating ON (but switch B LED stays at 33%)
                - Tap on switch B and the lights ramp up to 33%, the LED indicates ON, tap on again and the LED indicates ON but the lights don't change

                Scenario 3: set switch A and B defaults to 33%
                - Same as scenario 2

                Scenario 4: leave switch A and B default to 33%, removed both from scene, deleted scene, and recreated scene anew
                - Same as scenario 2

                These are model 24770, revision 0.2 4118.


                • #9
                  [USER="16851"]tajmirage[/USER] - do scenario #3 and then instead of a single-tap do a double-tap when you want it to go from 33% to full on and they will both respond. Also a double tap from either the On or off position will cause them to go instantly on or off.


                  • #10
                    It sounds like the slave switch might be a model 2477S relay, not a 2477D dimmer. Because the LEDs show the level of the switch’s built-in dimmer or relay, a model 2477S relay switch would show either on or off, depending on whether the relay was on or off, not a level.

                    Two dimmer features aren’t immediately obvious. One is as Sean described—a quick double-tap will turn both that switch and any linked responders ON 100% with an instant on rate, overriding any programmed dim level and ramp rate associated with the scene. The second is, if you tap a dimmer on, then sometime after tap the On paddle again, that will *toggle any connected load between the programmed dim level and 100%*, while still sending the regular On signal to any linked responders—a feature that comes in handy if you have a large scene and just want to brighten one member device.