Announcement

Collapse
No announcement yet.

Removing 2476D from scene (Hub V2 and Android original app)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Removing 2476D from scene (Hub V2 and Android original app)

    I am trying to remove an old 2476D from a scene (which works properly). I have the Hub V2 and (original style) of Android app.

    When I remove the switch with the app, it asks me to hold the Set button on the switch, I press OK for the app to continue and it does the job. The switch no longer is activated in that scene. However, the scene shows a "red" marker in the app at the end of running.
    If I add the switch back into the scene, the scene then includes it in operation and the red flag goes away.

    Is there a way to remove it AND get rid of the red flag?

    From what I can see the 2476 does not work with the new app.

    I am trying to delete 3 2476 switches/dimmers from my system as interacting with the Hub and app is not as smooth as the newer 2477 style. You need to do the press, hold, tap the Set button while programming with the app, which is not needed (from what I see) with the 2477
    Last edited by ricketyca; 05-04-2020, 10:09 AM.

    #2
    If you can add the 2476 device back to the scene and then remove it with an iOS device. I have heard that the android app will remove devices from the scene but still leaves some residual info behind.

    Comment


      #3
      Thanlks for the reply Sean. I don't have an iOS device available, so I will not be able to do that. Maybe I can borrow one later.

      Is it known what the situation really is? For instance, when the switch is removed is the hub retrying mulitple times to achieve the on/off, or is it just reporting that it did not get a reponse. What I am wondering is whether it is better overall to wire the switches (I am removing) into a circuit somewhere but not switching any load, or just disconnect them and accept the red markers.at the end of the scene or schedule operations.

      Also Sean, I see in other answers you have recommended a "hard remove from hub" option viz
      - Put the switch into unlink mode
      - Go to the Hub and press and hold it set button until you get a double beep.

      You have suggested that when people report that a switch is still operating as though it is in a scene after it was deleted. In my case, the switch does seem to get removed from the scene (as it no longer turns on/off) but the red marker shows up.

      Might that be an option for me?
      Last edited by ricketyca; 05-05-2020, 05:49 AM.

      Comment


        #4
        From what I have seen in the forums the issue only seems to only affect Android devices but what it is exactly I am not sure. The app does not have any documented features, other then the yellow flag, that alert the user to device issues so I am not sure about that either.

        Usually the red flag in the app is for open/close devices, or sensors, where red means open, or triggered, and white means closed, or idle. Scene icons do follow this pattern but the flag disappears as you noted earlier.

        The manual unlink process might be a good way to go. I don't see any reason not to try it. If it doesn't work, and the red flag bugs you, then disconnecting the load is an option. You might also be able to get Insteon support to login and remove the device for you but you would need to give them the login info.

        Comment


          #5
          Latest status: I tried (again) to remove the 2476 with the Android app. It takes it out of the scene but the scene flashes a red marker at the end. I then tried the "hard remove from hub" but to be honest the 2476 does not seem to go into the unlink mode the way its documentation suggests ....

          3) Press and hold SwitchLinc Set button until it double-beeps SwitchLinc status LED will flash once, then turn on solid

          No beeps come from my 2476. The LED flashes though and keeps flashing. I press another 3 seconds and the LED goes out.

          I return to the hub and hold the reset for a few seconds and get a beep followed by a double beep when I go back to the switch the LED is on and showing the load is off (at the bottom)

          The scenes where the switch was linked do not turn it off or on, but the scenes show a red marker after a few seconds

          So it does not seem to fix the issue. I have confirmed the same through the same switch and the other scene it was in. Exactly the same results.

          I have done the "force remove' via the app, so the switches are no longer showing, but the scene show red.

          Thanks for the advice

          Comment


          • TFitzpatri8
            TFitzpatri8 commented
            Editing a comment
            I don’t think there’s any good way to fix that. The best workaround I know is to rename that scene so it falls to the bottom of the list (I’ve named them zzzzz or similar), then just create a new scene without that device in it.

          #6
          Thanks TFitzpatri8 I think that is where I may go to. Create a new scene with only what I really want, but I might then also delete the old scene. Obviously it is less than ideal to have a scene where some extraneous signals are being pushed trying to make sure that everything has worked properly, when the device never responds. Fortunately neither of my "faulty" scenes run often so it is not a big deal. However another wrinkle is that my Google home can run the scenes sometimes "Hey Google, I'm going for wine" impresses visitors when the stairway and basement lights are activated! I am not sure whether deleting the old scene and naming the new one the same would avoid a HAL type reply "I'm sorry Rick I can't do that"

          Comment


          • TFitzpatri8
            TFitzpatri8 commented
            Editing a comment
            I would rename but not delete. If you go into settings, scene, notice that each existing scene has a scene number between 1-255. That’s what actually gets transmitted when you control that scene, turn hub xx.yy.zz scene number n on. If you delete it then create a new scene, at some point it will reuse that available scene number, then you are back to the same problem.

          #7
          Thanks for that insight!

          Comment


            #8
            To further add to the knowledge base - I removed the two 2476s and added in 2477 instead. I accidentally added one of those to a scene that I didn't mean to and not unexpectedly although no longer associated with the scene, it still turned on and off. So I added it back in and tried the new (Beta) app. It successully removed it from the scene and it no longer turns on and off with the scene. So there is a feature of the new app that saved borrowing an iOS device!

            It looks as though I will have both versions for a while and try to remember which to use depending on what I need to do!

            It is also interesting that the new app does not seem to report the error conditions (red circle) at the end of a scene that has "ghost" functions in it.

            Thanks again for those who commented. I hope the thread also helps other readers
            Last edited by ricketyca; 05-06-2020, 03:49 PM.

            Comment


              #9
              .. and more information - Problem Partly Solved!!!

              With a combinattion of beta and official Android apps, I was able to diagnose which device was causing the immediate error and resolve it.
              I had created a new scene with the same devices and the red marker showed up again for that scene. I decided that there must be some linking in a device that had not been cleared properly at some stage.

              This solution works for newly created scenes (it doesn't matter which app created them) that show a red marker. It does not resolve my old scenes which must have had some other ghost links too.

              After I created new scenes the red light warning still showed up on the official app. So I used the new app to delete all the devices (except one - the new app won't let you delete the last one).

              I tested with the old app and the red light did not show up.

              I added each item to the scene, one by one, retesting with the official app until I saw the red marker. When I added the one that was the culprit, using the beta app, I removed it.
              I also removed it from the other scene it was in. It was a 2457D2.

              Then I did a factory reset on the plug-in switch (2457D2). Although there is a flowchart in the user manual in did not seem to work, but apparently the easier method is to plug it in while holding the set button and waiting until the screeching stops.

              I then re-added the device to one of the scenes and tried the scene with the official app. The red marker did not come up.

              I repeated for the other scene it was in and that also worked correctly.

              I also was able to delete the last item in each "old, faulty" scene using the official app.

              So I now have active scenes with the devices working as needed. I have retained two "old, faulty" scenes with no schedule and no apparent devices in them.

              Following advice (earlier) from TFitzpatri8 I have left the two "old faulty" scenes in the hub so that the group/scene number does not get reused and potentially trigger some ghost or other kind of odd behaviour.

              Comment


                #10
                The need to jump through these hoops is maddening. I don't suppose there is any official Insteon staff monitoring this that can tell us where this bug is on the priority list? It's been this way for years and every time I have to touch my scenes, I cringe since I know my poor ol' Android app may or may not be able to properly configure a new or existing scene (when it comes to removing devices, that is).
                Hub: Hub 2 (39:35:10) | Phones: Samsung Galaxy S7 (Android 8.0) | Insteon devices: 25+

                Comment

                Working...
                X