Announcement

Collapse
No announcement yet.

App update Sept 22 - v1.1.3.3

Collapse
This is a sticky topic.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • App update Sept 22 - v1.1.3.3

    Just installed the new app update. Not seeing any differences at all. However it does seem to have broken my push updates (that I set via the iOS workaround). Will try to redo the settings, hopefully can be fixed. So other than another step back, anyone else notice anything?

  • #2
    No difference for me. Still a broken app since june update. Total crap. Period.
    No more insteon device for me. That's enough.

    Comment


    • #3
      The newest app seems to have addressed some issues (not sure if it released yesterday or today 9/23/2015), but here's some changes I've seen so far:

      I have text notifications back (by sending email to my phone's SMS E-mail address). This may very well have been fixed previously, but I just didn't dig into the right place to set it up as its not the same as iOS on Windows Phone. I have to go into the device I want to get notifications for, select the alert I want to get, and in the properties, change the e-mail to my phone's SMS Email address there and remove the phone number from the SMS field. It works now though, which makes me happy.

      My icons are now the right colors too.

      The app is no longer painfully slow to start (it now takes 5 seconds from tapping the icon to being logged in and at the QuickViews section.- it was previously taking 20 to 30 seconds).

      The only two issues I now have are:

      1. It still doesn't handle transitioning between Cellular <-> WiFi very well. If I change networks, I have to restart the app, If I leave it open and go back to the network in use when it started, it still works though.
      2. Push notifications are still not working. I've checked notification settings and it is enabled. I've uninstalled and reinstalled, and it still fails to work properly. Every time I open the app, I get the notification "Unable to open a push notification channel for this session" message. I get the same behavior on both 1520s. Given that I now get my text notifications though, this really doesn't bother me now.


      Comment


      • #4
        The update on 9/22 fixed a few things for me. I agree the 3 + buttons at the bottom is bad UI. However, I don't see any icons in the default appear icon library that would make sense. They should use a custom AppBar icon set for the buttons to make them visually different yet identifiable. This is custom appear 101. Use built-in, custom from Segoe UI Symbol, or custom image source. This is how you get the 'twitter button' with the bird in it, or in my other app, the one that looks like a car's check engine light.

        Push notifications still ‚Äčisn't working, but at least email to SMS now seems to work for me, so I won't complain too much about that.

        Comment


        • #5
          I think I've figured out the big factor that was messing up my access thru the new Windows Phone apps -- cameras. If I had a camera as a member of a room then I couldn't get the action buttons to work for that room. Having a camera as a member of my Favorites made it so no action items worked on the main view at all. After pulling cameras out of all the rooms and favorites I'm now able to get the action buttons to work.

          It was kind of nice having cameras as room members in the app, but I do have other camera apps so it's not the end of the world. It's a shame because they work fine in the full Windows 8.1 and 10 app (and this means I lose them their too), and used to work fine in the pre-June Windows Phone app. However, I guess I should have seen this coming since they broke the camera access for me in the Insteon Android app back in March (their the action buttons work - I just never see any camera pictures anymore).

          Admittedly, I'm doing something Insteon apparently doesn't like. I'm setting the local camera ports to 80 and then I either have the cameras blocked at the firewall or I use port address translation so that a couple of them are available externally on different ports. The Insteon hub camera setup actually goes into the cameras and reconfigures the ports to be the same internally as well as externally. This messes up other apps I have, so I set them up in the hub initially and then returned their ports back to where I'd originally had them. This worked fine for over a year as long as I was on a local Wifi, or when remote, a VPN connection. It would be nice if they had an "advanced camera setup" to allow providing the camera configuration settings manually, but I guess they're trying to make it easy for novices. Apparently, it's best to just leave cameras out of the Insteon realm as they don't play nicely. Thankfully I do have other more capable camera apps, who apparently have more dedicated development efforts.

          Anyway, removing cameras fixed most of my app problems including performance inside and outside my LAN (I can even see my thermostat again!).

          Comment


          • #6
            Originally posted by DiesIrae View Post
            I think I've figured out the big factor that was messing up my access thru the new Windows Phone apps -- cameras.
            Thanks for the hint, it is working!!!
            I have a camera integrated with the Insteon system added on the "Favorites" Home screen. The Windows APP was not working at all. I was able to see the list of all devices, but couldn't turn ON or OFF any single device, plus I could not click on the MORE menu of the device itself.
            I tried deleting the camera and now it is working.

            Can anybody from Support please troubleshoot this issue, please???

            Comment

            Working...
            X