Announcement

Collapse
No announcement yet.

Schedule is not working

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Schedule is not working

    Hello,
    I have two devices. I have tried adding a schedule to a device and tried adding both devices to a scene and having the scene have a schedule.
    Neither of the them work

    My current config looks like, would love any help or ideas.

    Thanks


    {
    "SceneID": 999999,
    "HouseID": 1111111,
    "SceneName": "Christmas Lights",
    "StatusDevice": "",
    "OnTime": "17:00",
    "OffTime": "23:00",
    "CustomOn": "",
    "CustomOff": "",
    "Group": 11,
    "IconID": 16,
    "Visible": false,
    "Favorite": false,
    "AutoStatus": false,
    "DayMask": 127,
    "TimerEnabled": true,
    "EnableCustomOn": false,
    "EnableCustomOff": false,
    "DeviceList": [
    {
    "DeviceID": 222222,
    "OnLevel": 100,
    "DeviceRoleMask": 3,
    "RampRate": 12,
    "DeviceGroupDetailID": 0
    },
    {
    "DeviceID": 333333,
    "OnLevel": 100,
    "DeviceRoleMask": 3,
    "RampRate": 12,
    "DeviceGroupDetailID": 0
    }
    ]
    }



    {
    "HouseID": 1111111,
    "DeviceID": 222222,
    "DeviceName": "The Tree",
    "InsteonID": "370000",
    "DeviceType": 0,
    "DevCat": 2,
    "SubCat": 55,
    "IconID": 46,
    "AutoStatus": false,
    "CustomOn": "",
    "CustomOff": "",
    "EnableCustomOn": false,
    "EnableCustomOff": false,
    "DimLevel": 254,
    "RampRate": 28,
    "OperationFlags": 0,
    "LEDLevel": 63,
    "AlertsEnabled": false,
    "AlertOn": 0,
    "AlertOff": 0,
    "Favorite": false,
    "Humidity": false,
    "DayMask": 0,
    "OnTime": "",
    "OffTime": "",
    "TimerEnabled": false,
    "Group": 4,
    "FirmwareVersion": 72,
    "LinkWithHub": 0,
    "BeepOnPress": false,
    "LocalProgramLock": false,
    "BlinkOnTraffic": false,
    "ConfiguredGroups": 1,
    "InsteonEngine": 2,
    "SerialNumber": "376729",
    "DeviceTypeTraits": {
    "SecurityDevice": false,
    "TypeDescription": "On/Off Module"
    },
    "GroupList": []
    }



    {
    "HouseID": 1111111,
    "DeviceID": 333333,
    "DeviceName": "Outside Light",
    "InsteonID": "420000",
    "DeviceType": 0,
    "DevCat": 2,
    "SubCat": 42,
    "IconID": 33,
    "AutoStatus": false,
    "CustomOn": "",
    "CustomOff": "",
    "EnableCustomOn": false,
    "EnableCustomOff": false,
    "DimLevel": 254,
    "RampRate": 28,
    "OperationFlags": 0,
    "LEDLevel": 63,
    "AlertsEnabled": true,
    "AlertOn": 0,
    "AlertOff": 0,
    "Favorite": false,
    "Humidity": false,
    "DayMask": 127,
    "OnTime": "00:00",
    "OffTime": "00:00",
    "TimerEnabled": true,
    "Group": 5,
    "FirmwareVersion": 69,
    "LinkWithHub": 0,
    "BeepOnPress": false,
    "LocalProgramLock": false,
    "BlinkOnTraffic": false,
    "ConfiguredGroups": 1,
    "InsteonEngine": 2,
    "SerialNumber": "424EED",
    "DeviceTypeTraits": {
    "SecurityDevice": false,
    "TypeDescription": "On/Off Switch"
    },
    "GroupList": []
    }

  • #2
    this ended up being the hub local time setting. You can only view and set this via the app. That info is not available via the api. It is now working

    Comment

    Working...
    X