Announcement

Collapse
No announcement yet.

Insteon Hub not powering on

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Insteon Hub not powering on

    I have an Insteon hub (2245-222) that I have been using for about 6 months with few problems. It was controlling about 5 devices in my house.

    However, yesterday it stopped working or giving any sign of life... the status LED on the top front edge is completely dark; not red, green, or blinking... just dark.

    I checked the power, and the cord is plugged into a good outlet and a voltmeter test showed that power is getting to the Hub. I unplugged the Hub, waited, plugged back in, used the reset button, and waited for any sign of life... nothing. It is plugged directly into my router, and all my other devices have good connectivity between each other, the Internet, etc. I have switched the Ethernet cable to different ports on the back of the router, with no better results. This problem is only affecting the Insteon Hub.

    Does the absence of any life in the status LED mean it's bricked? What else can I try? I have verified it's getting power...

    Futuremoose

  • #2
    Did you try unplugging and replugging the power cable at the Hub end? If nothing helps, then there's still the warranty
    Stu's Views is Education and Fun. What do YOU want to VIEW today?
    MathLandia High school mathematics learning fun.
    Both Stu's Views and MathLandia are free websites that do not sell anything.
    Saving energy is not always free. Be a world saver.

    Please don't PM with questions that can be asked in a forum.

    Comment


    • #3
      Yes, I tried that... first thing. Did not help. My next adventure; Warranty-Land.

      Comment


      • #4
        Had the same problem with my hub a few days ago. Not responding and no light on the hub. Many have experienced a problem in the power supply section on the board. Several people posted in the beta test forum that they had the same problem. They replaced C7, a 47uf 50v capacitor and that fixed their problem. I decided to give it a try and that turned out to be the same problem I had with my hub. I replaced C7 with a new capacitor I ordered from Digikey and that fixed it. Some suggested that Insteon is using a 100uf in parallel with a 10uf SMD both 50v in the position of C7. I hope this helps someone since it helped me.

        Comment

        Working...
        X