Announcement

Collapse
No announcement yet.

HouseLinc fails to connect to 2413U PLM

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • HouseLinc fails to connect to 2413U PLM

    I purchased a 2413U PLM to use with HouseLinc on a Thinkpad T42 laptop that runs WinXP Pro SP3. I've installed FTDI driver 2.8.30, the laptop detects the 2413U as COM6 - Device Manager says the USB COM6 port is working. However, HouseLinc (2.10.25) fails to recognize it. I've tried removing and reinstalling the FTDI drivers to no avail. What am I missing? Any help would be appreciated. This is my first USB PLM, I have used HouseLinc with serial PLMs on other PCs with COM ports seamlessly. Thank you.

  • #2
    Have you tried to manually configure the gateway?
    Stu's Views is Education and Fun. What do YOU want to VIEW today?
    MathLandia High school mathematics learning fun.
    Both Stu's Views and MathLandia are free websites that do not sell anything.
    Saving energy is not always free. Be a world saver.

    Please don't PM with questions that can be asked in a forum.

    Comment


    • #3
      Not sure what you mean by configuring the gateway. Using the HouseLinc tool to select the 2413U PLM doesn't work. Do I need to configure the COM6 port parameters directly? The device instance ID associated with USB Serial Port COM6 is FTDIBUS\VID_0403+PID_6001+A60332RNA\0000. Are registry changes required to ignore the serial number? . Is there an Insteon document that explains what to do?

      Comment


      • #4
        Below is a fix for the latest version of the PLM not being recognized.
        http://www.insteon.com/support-knowl...c?rq=houselinc
        Last edited by BLH; 07-25-2015, 03:37 PM.

        Comment


        • #5
          Originally posted by efahnoe View Post
          Not sure what you mean by configuring the gateway. Using the HouseLinc tool to select the 2413U PLM doesn't work. Do I need to configure the COM6 port parameters directly? The device instance ID associated with USB Serial Port COM6 is FTDIBUS\VID_0403+PID_6001+A60332RNA\0000. Are registry changes required to ignore the serial number? . Is there an Insteon document that explains what to do?
          If a gateway is not found automatically, then you can use the option to manually configure the gateway. Several choices are available. The option is in blue at the bottom left of the pane.
          Stu's Views is Education and Fun. What do YOU want to VIEW today?
          MathLandia High school mathematics learning fun.
          Both Stu's Views and MathLandia are free websites that do not sell anything.
          Saving energy is not always free. Be a world saver.

          Please don't PM with questions that can be asked in a forum.

          Comment


          • #6
            I've updated the devices.xml file in the the HouseLinc data folder as suggested by BLH. Same result, no gateway found. I note that the serial number of the FTDI chip in the 2413 PLM shows up during the automatic gateway scan as does the COM6 port assigned to the chip. I've always tried manual configuration of the 2413U USB modem too. But no valid gateway is found. Is this a registry issue? Thanks.

            Comment


            • #7
              I have heard that there is a new update to the devices.xml file. It is currently being tested and will release shortly.

              Comment


              • #8
                The file has been updated. It can still be found at the same location. See below:

                http://www.insteon.com/support-knowl...c?rq=houselinc

                Please let me know if this does work for you.

                Comment


                • #9
                  If you're using Windows 8.1: the Devices.xml file is located in Users>Public>SmartLabs>HouseLinc
                  Stu's Views is Education and Fun. What do YOU want to VIEW today?
                  MathLandia High school mathematics learning fun.
                  Both Stu's Views and MathLandia are free websites that do not sell anything.
                  Saving energy is not always free. Be a world saver.

                  Please don't PM with questions that can be asked in a forum.

                  Comment


                  • #10
                    I bought a new PLM 2413U because my old one stopped working. I tried everything and it would not be recognized. When I opened houselinc, it showed the address of the old 2413U.‚Äč
                    So as a last resort, I edited the c:\Users\Public\SmartLabs\HouseLinc\Settings\House Linc.settings.xml. I searched for all of the old 2413U address instances and replaced them with the new address of the 2413U. I had to close out of houselinc and go back in. It showed the new address and everything worked. I would advise making a backup of the file first. I am running windows 10.

                    Comment


                    • #11
                      You may have been able to use the later devices.xml file pointed to in a previous post in this thread.
                      Though editing is another way around the newer device information needed to work.

                      Comment


                      • #12
                        When I try to add my PLM manually, I get a weird UI glitch and I can't continue the wizard to the next page because I can't see the inputs at the bottom of the window that are cut off. What sequence of tab and arrow keys can get me around this?

                        Comment


                        • #13
                          There's not a scroll bar, but you can stretch the window vertically.
                          Stu's Views is Education and Fun. What do YOU want to VIEW today?
                          MathLandia High school mathematics learning fun.
                          Both Stu's Views and MathLandia are free websites that do not sell anything.
                          Saving energy is not always free. Be a world saver.

                          Please don't PM with questions that can be asked in a forum.

                          Comment


                          • #14
                            I tried. That window doesn't allow it. I tried maximizing it to, also to no avail. I considered the existence of a window "interface tweaking tool" that can force resize other programs. I want to say I've done that some time ago with .net. But that seemed a bit desperate.

                            After much trying, I found that after installing houselinc, and then plugging in the plm, the plm's internal ftdi chip wasn't properly being recognised in windows. I used windows hardware manager to search for a better driver, and it found out and installed, and then the autodiscovery worked in houselinc. Thank god!

                            Comment


                            • #15
                              FOUND THE ISSUE: (below problem fix for Windows 7 is the same as Windows 8.1 fix above)

                              Newly purchased 2413U problem with Windows 7 - HouseLinc does not detect the PowerLinc.
                              The posted fix does not work because it appears there was no "Devices.xml" in this Windows 7 version (2.10.25 for Windows 7). The only file containing XML is called "HouseLinc.exe.config"

                              Please help?
                              Last edited by JohnQPublic; 02-09-2018, 02:56 PM.

                              Comment

                              Working...
                              X